RFC-documenten – voluit Request for Comments – zijn documenten die de protocollen en andere aspecten van het internet beschrijven. De RFC-documenten komen tot stand door een discussie- en publicatieproces dat wordt georganiseerd door de RFC Editor. Ze worden uiteindelijk als standaard bekrachtigd door de Internet Engineering Task Force.
De RFC-documenten zijn doorzoekbaar op de website van de RFC Editor. Op deze site is ook allerlei informatie te vinden over de totstandkoming van RFC's en Internet-standaarden.
Geschiedenis De eerste RFC's werden uitgegeven in 1969 in verband met het ARPANET-project, de voorloper van het internet. Omdat elektronische distributie nog in de kinderschoenen stond, werden de eerste RFCs uitgetypt en met de post verstuurd naar de onderzoekers van ARPA.
De allereerste RFC (RFC 1, getiteld "Host Software") werd op 7 april 1969 gepubliceerd door Steve Crocker van de University of California, Los Angeles. In 2009 werd herdacht dat het veertig jaar geleden is dat deze eerste RFC werd uitgegeven.New York Times, 7 april 2009, How the Internet got its rules
RFC-documenten op Wikipedia Van de volgende RFC-documenten is een beschrijving op de Nederlandstalige Wikipedia te vinden: 768: UDP, zie User Datagram Protocol 791: IP, zie Internet Protocol 793: TCP, zie Transmission Control Protocol 812: Nickname/Whois-protocol 954: Nickname/Whois-protocol, update van 812 959: FTP, zie file transfer protocol 1055: SLIP, zie Serial Line Internet Protocol 1142: IS-IS zie Intermediate System-to-Intermediate System 1247: OSPF zie Open Shortest Path First 1918: beschrijft de privé-adresruimte van IP-adressen 1939: POP3 1945: HTTP 1.0, zie Hypertext Transfer Protocol 2229: DICT 2397: Inline image 2460: IPv6, zie Internet Protocol versie 6 2616: HTTP 1.1, zie Hypertext Transfer Protocol 2821: SMTP, zie Simple Mail Transfer Protocol 3920: XMPP-Core, zie Extensible Messaging and Presence Protocol 3921: XMPP-IM, zie Extensible Messaging and Presence Protocol 3922: XMPP-CPIM, zie Extensible Messaging and Presence Protocol 3923: XMPP-E2E, zie Extensible Messaging and Presence Protocol
1 april-RFC's Door de jaren heen is het traditie geworden om op 1 april een RFC te publiceren met een humoristisch voorstel. Voorbeelden hiervan zijn RFC 1149 (1 april 1990), die IP-verbindingen per postduif beschrijft en RFC 2324, die een hypertekstprotocol beschrijft om koffiezetapparaten te bedienen. Op 1 april 1998 verscheen RFC 2322, waarin een voorstel werd gedaan om IP-adressen met behulp van wasknijpers toe te wijzen. Dit was een methode die op Hacking in Progress in 1997 daadwerkelijk was toegepast, een jaar eerder.
Externe links RFC Editor Internet Engineering Task Force
Categorie:Internetprotocol