Het Internet Protocol over Avian Carriers (IPoAC) is een netwerkprotocol voor draadloze point-to-pointverbindingen met behulp van postduiven. IP over Avian Carriers werd oorspronkelijk beschreven in RFC 1149, uitgegeven door de Internet Engineering Task Force, geschreven door David Waitzman en uitgebracht op 1 april 1990. Het is een van de meerdere 1 aprilgrappen op de RFC-verzoekpagina's.

Waitzman beschreef in de RFC 2549 IP over Avian Carriers with Quality of Service van 1 april 1999 een verbetering van het protocol. In 2011, als derde aprilgrap, maakte de RFC 6214 Adaptation of RFC 1149 for IPv6 het mogelijk om deze technologie aan te passen voor het transport met IPv6-datagrammen.

IPoAC werd met succes geïmplementeerd, maar slechts voor negen datapakketten, met een pakketverliesratio van 55% en een responstijd variërend van 3.000 seconden (50 min) tot meer dan 6.000 seconden (100 min). Deze technologie heeft bijgevolg last van hoge latentie.

Categorie:Internetprotocol